Articulate 360 Desktop App: Creators can’t sign in

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 20:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 19:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 21, 2026 - 19:00 UTC

Investigating

We’re seeing an issue where Creators can’t sign in to the Articulate 360 desktop app.

You may see sign-in failures or get stuck during login. This impacts launching and updating apps from the desktop app.

Our team is investigating now. We’ll share updates as we learn more.
Posted Apr 21, 2026 - 18:31 UTC
This incident affected: Articulate ID and Articulate 360 (Articulate 360 Desktop App Updates).