Articulate 360: Problems uploading and viewing images in Rise 360 and Review 360
Incident Report for Articulate
Resolved
We've confirmed that Rise 360 and Review 360 are working normally.
Posted 6 months ago. Mar 19, 2019 - 17:10 UTC
Monitoring
We've just pushed out a fix, and images in Rise 360 and Review 360 are working normally. We'll continue to monitor performance carefully.
Posted 6 months ago. Mar 19, 2019 - 16:03 UTC
Investigating
Hi there, Articulate 360 users. Right now, uploading and viewing images in Rise 360 and Review 360 is unavailable. We’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for the trouble.
Posted 6 months ago. Mar 19, 2019 - 15:25 UTC
This incident affected: Articulate 360 (Review, Rise).