Rise 360: Dashboard and Authoring are currently unavailable

Incident Report for Articulate

Postmortem

On March 11th 2025, Articulate 360 had an outage due to system misconfiguration. We are committed to ensuring that all of our products are highly available so that you have what you need, when you need it. After a detailed analysis, we're now sharing what happened, how we responded, and the steps we've taken to improve our systems and processes going forward.

Incident Details

On March 11, 2025, Rise 360 was unavailable for 70 minutes. At 07:34ET Rise 360 on-call engineers were paged due to a failing service health check monitor. Our incident response plan was activated and the on call Product Engineer began coordinating resolution. Engineers identified the root cause of the issue as a misconfigured environment variable used by many services in our infrastructure. This was caused by a duplicate definition of the environment variable. Engineers took steps to reset the environment variable and redeploy services to bring them back up. Service was restored for all customers, at 08:44ET.

As a result of this incident, we have identified the following actions:

  • Update policies and documentation for engineers to clarify environment variable definition standards to prevent duplicate definitions.
  • Improve our deployment pipelines to decrease the recovery time of our services when there are errors.

Articulate’s Commitment to Excellence

Every day, you entrust Articulate with the crucial mission of training your customers, employees, and teams—a responsibility we take very seriously and value deeply.

We’re sorry for any inconvenience the recent incident may have caused, impacting the smooth and efficient service we constantly aim to deliver.

We are fully committed to learning from this experience and strengthening our pledge to support your ongoing success and satisfaction.

Posted Apr 02, 2025 - 12:12 UTC

Resolved

Rise 360 is performing normally, and this issue has been resolved.
Posted Mar 11, 2025 - 15:48 UTC

Monitoring

Rise 360 access has been restored and is fully functional. If you're still experiencing an issue, please reach out to our Support team support@articulate.com.
Posted Mar 11, 2025 - 15:09 UTC

Investigating

Hi, all! We’re aware of an issue affecting Rise 360 Dashboard and Rise Authoring. Our team is actively investigating and working to resolve the issue as quickly as possible. We’ll provide updates as we have more information. Thank you for your patience.
Posted Mar 11, 2025 - 14:49 UTC

Monitoring

We are pleased to report that Rise 360 access has been restored and is fully functional. If you're still experiencing an issue, please reach out to our Support team support@articulate.com.
Posted Mar 11, 2025 - 13:58 UTC

Investigating

We’re aware of an issue affecting Rise 360 Dashboard and Rise Authoring. Our team is actively investigating and working to resolve the issue as quickly as possible. We’ll provide updates as we have more information. Thank you for your patience.
Posted Mar 11, 2025 - 12:57 UTC
This incident affected: Articulate 360 (Rise 360).