Articulate Localization: Certain Google Languages are Failing to Translate

Incident Report for Articulate

Update

We are continuing to investigate this issue.
Posted Nov 19, 2025 - 16:18 UTC

Update

We are continuing to investigate this issue.
Posted Nov 19, 2025 - 14:23 UTC

Investigating

We are continuing to investigate an issue affecting Articulate Localization in Rise 360 and Storyline 360. Currently, content isn’t translating as expected when selecting certain languages. Creators may notice that the following languages fail to translate:

Khmer
Luxembourgish
Lao
Maori
Nepali
Nyanja
Samoan
Tetum
Tigrinya

We’ll share more updates as soon as we learn more!
Posted Nov 19, 2025 - 14:01 UTC
This incident affects: Articulate 360 (Rise 360, Articulate 360 Desktop App Updates, Localization).