Rise 360: PDF exports are delayed

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 21:12 UTC

Monitoring

PDF exports in Rise 360 are processing normally again. We’re monitoring to confirm performance remains stable.
Posted Aug 19, 2026 - 20:46 UTC

Investigating

PDF exports in Rise 360 are taking longer than expected to complete. We’re investigating the delays and working to restore normal processing.
Posted Aug 19, 2026 - 20:10 UTC
This incident affected: Articulate 360 (Rise 360).