Articulate 360: Rise 360 is currently unavailable
Incident Report for Articulate
Resolved
We've resolved this issue. Rise 360 courses are loading normally again. We're sorry for any trouble!
Posted Aug 27, 2019 - 19:46 UTC
Monitoring
We've implemented a fix for this issue, and Rise 360 courses should now load as expected. Please refresh your browser. We'll continue to monitor performance carefully.
Posted Aug 27, 2019 - 19:21 UTC
Identified
We've identified the issue and are working on a fix. We'll keep you updated as we progress.
Posted Aug 27, 2019 - 18:41 UTC
Investigating
We're investigating an issue that's preventing some Rise 360 courses from loading. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Aug 27, 2019 - 17:58 UTC
This incident affected: Articulate 360 (Rise 360).