Rise 360: Vimeo videos not playing correctly.

Incident Report for Articulate

Update

We are continuing to work on a resolution for this issue.
Posted Feb 25, 2026 - 18:11 UTC

Update

We are continuing to work on a resolution for this issue.
Posted Feb 25, 2026 - 17:05 UTC

Identified

We've identified an issue preventing Vimeo videos from playing correctly in Rise 360. This affects both new courses in the authoring tool and previously published courses in your LMS.
The issue is caused by a third-party provider. We'll share an update within the next hour.
Posted Feb 25, 2026 - 15:54 UTC
This incident affects: Articulate 360 (Rise 360).