Rise 360: Degraded Performance

Incident Report for Articulate

Resolved

This incident has been resolved. Rise 360 is now operating normally.
Posted Mar 25, 2026 - 20:54 UTC

Monitoring

We’ve implemented a fix for the issue causing degraded performance in Rise 360.

Creators should now see improved performance when opening and editing courses. We’re continuing to monitor the system to ensure everything remains stable.
Posted Mar 25, 2026 - 19:54 UTC

Investigating

We’re seeing degraded performance in Rise 360. Some Creators may notice that parts of Rise are slow, unresponsive, or not working as expected when opening or editing courses.
We’re investigating the issue now and working to identify the cause.
We’ll share an update as soon as we have more details. If you need help in the meantime, reach out to our support team at support@articulate.com
Posted Mar 25, 2026 - 18:47 UTC
This incident affected: Articulate.com.