Articulate 360 Login Issues

Incident Report for Articulate

Resolved

This issue is now resolved, and you should be able to log in normally. If you run into any trouble, please reach out to our Support team at articulatecase.com. Thank you!
Posted Jun 11, 2024 - 17:26 UTC

Monitoring

Our team has released a fix for this issue. To see your subscription status, reload the 360.articulate.com site and log in again. Please let us know if you have any trouble.
Posted Jun 11, 2024 - 16:16 UTC

Update

We are continuing to investigate this issue.
Posted Jun 11, 2024 - 15:49 UTC

Investigating

We're experiencing issues with some users unable to log into Articulate 360 apps, use the tools, or see an incorrect subscription status. We're looking into what went wrong and will let you know as soon as we have more information. We're so sorry for the trouble!
Posted Jun 11, 2024 - 15:31 UTC
This incident affected: Articulate 360 (Rise 360, Review 360, Reach 360, Team Slides, Articulate 360 Desktop App Updates, Storyline 360 Text to Speech, Articulate 360 Training, Content Library 360, Content Library Images 360, Account Management).