articulate.com and Articulate 360 account management: Degraded performance
Incident Report for Articulate
Resolved
We've confirmed that everything is working normally.
Posted Jul 12, 2018 - 19:49 UTC
Investigating
Hi there, articulate.com visitors and Articulate 360 customers. You may run into errors on our website right now when trying to purchase Articulate 360 subscriptions, add seats to an existing Articulate 360 subscription, open support cases, or navigate our support content. We're working on getting this fixed, and we'll keep you updated. We're so sorry for the trouble.
Posted Jul 12, 2018 - 18:32 UTC
This incident affected: Articulate.com.