Ordering: Temporarily paused due to cloud service provider issues

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:42 UTC

Investigating

We’ve paused ordering to prevent processing errors caused by issues with our cloud service provider. This helps us avoid failed transactions and ensure accuracy once services stabilize.
We’re actively investigating and will share updates as we learn more.
Thanks for your patience while we work through this.
Posted Oct 20, 2025 - 16:07 UTC
This incident affected: Articulate 360 (Account Management).