Localization: Translation failures with DeepL glossaries

Incident Report for Articulate

Update

Rise 360 and Storyline 360 customers using a glossary for translation may experience translation failures. Glossary creation continues to be impacted. We’re working with our upstream providers to investigate the issue. Translations appear stable when a glossary is not used.
Posted Jun 22, 2026 - 18:12 UTC

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 16:33 UTC

Investigating

Rise 360 and Storyline 360 customers using a glossary for translation may experience translation failures. We’ve identified an issue with DeepL glossary creation and are investigating. Translations that don’t use a glossary are not affected at this time.
Posted Jun 22, 2026 - 15:30 UTC
This incident affects: Articulate 360 (Localization).