Articulate 360: Existing Articulate 360 users might be unable to join a Articulate 360 Teams trial or subscription
Incident Report for Articulate
Resolved
We've confirmed that everything's working normally.
Posted 3 months ago. May 07, 2019 - 19:59 UTC
Monitoring
We've fixed this issue, and we're keeping a close eye on things. We'll keep you posted.
Posted 3 months ago. May 07, 2019 - 17:24 UTC
Identified
We’ve identified the cause of this issue, which is preventing inactive Articulate 360 trial users from receiving their email invitation to join an Articulate 360 Teams subscription. We’re working on a fix and will keep you updated. So sorry for the trouble.
Posted 3 months ago. May 07, 2019 - 16:42 UTC
Update
We are continuing to investigate this issue.
Posted 3 months ago. May 07, 2019 - 16:21 UTC
Update
We are continuing to investigate this issue.
Posted 3 months ago. May 07, 2019 - 15:51 UTC
Investigating
We’ve identified an issue that may prevent folks with existing Articulate IDs from being able to join an Articulate 360 Teams trial or subscription. We’re working on a fix and will let you know as soon as we have more information.
Posted 3 months ago. May 07, 2019 - 15:51 UTC
This incident affected: Account Management.