Articulate 360: Articulate Webpages Aren't Loading
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 22:02 UTC
Monitoring
Our team has implemented a fix. We are monitoring it closely.
Posted Mar 05, 2024 - 20:58 UTC
Investigating
Hi Articulate 360 users! You might find that Rise 360 courses and the Account Management dashboard are not loading. Our team is investigating the issue. We’ll report back when we have an update. Sorry for the inconvenience!
Posted Mar 05, 2024 - 20:24 UTC
This incident affected: Articulate 360 (Rise 360, Account Management).