Purchasing Storyline 3, Studio ’13, and Articulate Online is unavailable
Incident Report for Articulate
Resolved
We've confirmed that our online store is back up and running normally. So sorry for any trouble!
Posted 2 months ago. Apr 17, 2019 - 15:51 UTC
Investigating
Hi there. Currently purchasing Storyline 3, Studio ’13, and Articulate Online is unavailable. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted 2 months ago. Apr 17, 2019 - 13:16 UTC
This incident affected: Store.