Articulate 360: Issues with accepting Articulate 360 Teams invitations
Incident Report for Articulate
Resolved
We've confirmed that invitations are working normally.
Posted 15 days ago. Oct 08, 2019 - 00:26 UTC
Monitoring
Invitations are now working normally, and we're keeping a close eye on things.
Posted 15 days ago. Oct 07, 2019 - 20:44 UTC
Investigating
Hi, Articulate 360 users. We're investigating an issue that's preventing users who don't already have an Articulate ID from accepting Articulate 360 Teams invitations. We'll let you know as soon as we have more info. We're so sorry for any trouble!
Posted 15 days ago. Oct 07, 2019 - 19:53 UTC
This incident affected: Articulate ID and Account Management.