Rise 360: Issue Saving Content from Course Overview Menu

Incident Report for Articulate

Resolved

This incident has been resolved. If you're having trouble with Rise 360 lessons, please refresh your browser on the course overview page. You can always connect with our Support team here, https://access.articulate.com/support/contact/360-teams.
Posted Sep 15, 2025 - 19:22 UTC

Investigating

We’ve identified an issue in Rise 360 where content added to blank lessons through the Course Overview Menu isn’t saving as expected. This affects authors building or editing lessons directly from the menu.
Please refresh your Course Overview page after making changes to ensure your content appears as expected.
Our team is actively working on a fix. We will post another update within 60 minutes or as soon as we have more details. Thank you for your patience—we know how important it is to keep your course content intact.
Posted Sep 15, 2025 - 18:14 UTC
This incident affected: Articulate 360 (Rise 360).