Rise 360: AI audio workflow not loading

Incident Report for Articulate

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 16:36 UTC

Investigating

We’re investigating an issue where the AI audio workflow isn’t loading in Rise 360.

Creators may see the workflow fail to load due to a third party request timing out. As a result, AI audio can’t be generated or edited right now in Rise 360.

We’re working with our provider to resolve the timeout and restore functionality. We’ll share another update as soon as we have more information.
Posted Feb 25, 2026 - 15:10 UTC
This incident affects: Articulate 360 (AI Assistant).