We've resolved the issue affecting Articulate ID that prevented users from logging in and creating Articulate 360 trials. All systems are now working normally.
Posted Nov 12, 2025 - 19:50 UTC
Update
Everything continues to run smoothly. Users can log in and access Articulate 360 apps without trouble.
We’re still investigating the root cause. We’ll keep monitoring and share another update once we wrap up that work.
Posted Nov 12, 2025 - 18:05 UTC
Monitoring
We aren’t seeing new login errors with Articulate ID. Access to Articulate 360 apps is working as expected right now.
We’re monitoring closely in case the issue returns. If we see more trouble, we’ll update this status right away. Thanks for hanging in there!
Posted Nov 12, 2025 - 16:56 UTC
Investigating
We’re currently investigating an issue that’s preventing users from logging in, staying logged in, and creating Articulate 360 trials. This affects access to all Articulate 360 apps.
We know this is disruptive, and we’re working to restore access as quickly as we can. We’ll share more as soon as we know more!
Posted Nov 12, 2025 - 16:11 UTC
This incident affected: Articulate 360 (Rise 360, Review 360, Reach 360, Team Slides, Articulate 360 Desktop App Updates, Storyline 360 Text to Speech, Articulate 360 Training, Content Library 360, Content Library Images 360, Account Management, AI Assistant, AI Images, Localization) and Articulate ID.