Rise 360 Quick Share: Quick Share courses not loading

Incident Report for Articulate

Resolved

We've resolved the issue that prevented Rise 360 Quick Share courses from loading. If you're still unable to load a Quick Share course, please refresh your browser and try again. Thank you for your patience.
Posted Jul 20, 2026 - 18:02 UTC

Investigating

Some customers are unable to load Rise 360 Quick Share courses. We're investigating the issue and working to identify the cause. We'll share more information here as soon as it's available.
Posted Jul 20, 2026 - 16:49 UTC
This incident affected: Articulate 360 (Rise 360).