Articulate Localization: Timeouts when translating some languages when using Glossaries

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 19:40 UTC

Update

This incident has been resolved.
Posted Mar 16, 2026 - 17:22 UTC

Monitoring

A fix has been implemented and translations are working as expected again. We’re continuing to monitor performance to ensure the service remains stable.
Posted Mar 16, 2026 - 16:24 UTC

Investigating

We’re investigating reports of timeouts when translating certain languages that use glossaries in Localization.
Some customers may see a potential interruption in service when using Glossaries in Rise 360 and Storyline 360.
Our team is actively looking into the issue and working to identify the cause. Thank you for your patience.
Posted Mar 16, 2026 - 15:55 UTC
This incident affected: Articulate 360 (Localization).