Articulate 360: Potential error when logging in to the desktop app
Incident Report for Articulate
Postmortem

On Tuesday August 27 beginning at 12:55 UTC, Articulate 360 desktop users were intermittently unable to sign in to Articulate 360 for ten hours and nine minutes. This outage happened because the third-party provider we depend on for user authentication began intermittently serving an invalid TLS/SSL certificate for our user login site id.articulate.com.

This outage period is unacceptable. We're very sorry for how it impacted your workday.

We'd like to provide more info about how this happened and what we're doing to prevent it from happening again. Our team was completely focused on resolving this issue throughout the outage. Our vendor was unacceptably slow in identifying the root cause of the outage and resolving it. We take responsibility for choosing vendors that provide consistent high level of service, and that’s why we’re working hard with this vendor to make sure this doesn’t happen again. We’ve made three major changes:

  1. First, while we had premium support in place already, we have upgraded our support contract with our vendor to ensure an even higher level of response and escalation for critical issues and outages.
  2. We also secured a commitment from the vendor to provide a Root Cause Analysis (RCA) regarding the issue we experienced. We spoke with them on a daily basis to ensure this was moving forward. On Wednesday September 11, our vendor provided their RCA, which outlined that one server behind their load balancer was misconfigured, partly due to an error in their server provisioning process and partly due to an involved engineer's unfamiliarity with the process. They did not notice the discrepancy until we opened our support ticket.
  3. In addition to the improvements we've already put in place to ensure priority response and resolution, our vendor has committed to several improvements to ensure this doesn't happen again, including:

    1. Revising internal training procedures so their engineering team is aware of custom domain router requirements.
    2. Implementing resilient automated error checking to ensure custom TLS certificates are compliant.

We will continually monitor this vendor’s level of service to ensure they’re meeting our expectations. If you have any questions, please get in touch with our support team and we'll be happy to provide any detail we can.

Posted 2 days ago. Sep 20, 2019 - 13:31 UTC

Resolved
We've resolved this issue. Users can log in to Articulate 360 and E-Learning Heroes normally again. We're sorry for any trouble!
Posted 26 days ago. Aug 27, 2019 - 22:00 UTC
Monitoring
We've implemented a fix for this issue, and users should now be able to log in to Articulate 360 and E-Learning Heroes normally again. We'll continue to monitor performance carefully.
Posted 26 days ago. Aug 27, 2019 - 20:50 UTC
Identified
We've identified the issue that's causing some users to receive an error when logging in to Articulate 360 and E-Learning Heroes, and we're working on a solution. If you experience this, please wait a moment and try logging in again. We'll share an update when we have more info.
Posted 26 days ago. Aug 27, 2019 - 19:49 UTC
Update
We're continuing to investigate this issue, which may impact users who are trying to log in to Articulate 360 and E-Learning Heroes, as well.
Posted 26 days ago. Aug 27, 2019 - 14:12 UTC
Investigating
We're investigating an issue that may cause users to receive an error when logging in to the Articulate 360 desktop app. If you experience this, please wait a moment and try logging in again. We'll let you know when we have more info.
Posted 26 days ago. Aug 27, 2019 - 13:36 UTC
This incident affected: Articulate ID.