Reach 360: Intermittent access

Incident Report for Articulate

Resolved

This incident has been resolved. Reach 360 is fully operational.
Posted Nov 04, 2025 - 19:21 UTC

Monitoring

We’re investigating intermittent issues that may prevent users from accessing Reach 360. Some may be unable to log in or use the product reliably. We’ve made a change and are currently monitoring performance to confirm stability.
Posted Nov 03, 2025 - 21:17 UTC
This incident affected: Articulate 360 (Reach 360).