Rise 360 is unavailable
Incident Report for Articulate
Postmortem

On Monday, March 23 and Tuesday, March 24 Rise 360 customers were intermittently unable to log in, create courses, and manage and take courses in Rise 360 for a total of 4 hours.

We know the reliability of our apps is very important to you and your business. Outages are unacceptable, and we're sorry for how this incident impacted you.

We'd like to give you a little more information about how this situation unfolded:

  • Starting at 4:55 pm UTC on March 23, our servers experienced a large surge in traffic. This traffic surge prevented other users from accessing Rise 360.
  • The situation was resolved at 7:55 pm UTC and we continued to monitor as traffic returned to normal.
  • At 3:15 pm UTC on March 24, we detected another large traffic surge, resulting in users once again being unable to access Rise 360.
  • Our team immediately took steps to address the issue and we were able to get Rise 360 fully operational by 5:16 pm UTC.

We’ve made improvements in two key areas to prevent this kind of situation from happening again:

  1. We’ve increased application performance and scalability to accommodate future large surges in traffic.
  2. And, we’ve improved communication within Rise 360 to inform you when app performance isn’t meeting expectations.

We have additional changes rolling out in the next few weeks to better handle user connections. We’re continuing to improve course caching for faster load times and also making other performance optimizations for course authoring and for the Rise 360 dashboard.

If you have any questions, please get in touch with our support team and we'll be happy to help.

Posted Apr 16, 2020 - 21:13 UTC

Resolved
We've confirmed that Rise 360 is performing normally.
Posted Mar 24, 2020 - 21:30 UTC
Monitoring
Rise 360 is back up and running, and we're monitoring its performance carefully.
Posted Mar 24, 2020 - 16:26 UTC
Investigating
Hi there, Articulate 360 customers. Right now, Rise 360 may not be available for all users. We're so sorry for the trouble, and we're investigating what's causing this. We'll keep you posted.
Posted Mar 24, 2020 - 15:18 UTC
This incident affected: Articulate 360 (Rise 360).