Review 360 is currently unavailable

Incident Report for Articulate

Resolved

This issue is resolved. We've confirmed that Review 360 is working as expected.
Posted Jan 15, 2020 - 16:41 UTC

Monitoring

Review 360 is back up and running. We'll continue to monitor performance carefully.
Posted Jan 15, 2020 - 15:12 UTC

Investigating

Review 360 is currently unavailable, and we're looking into what went wrong. We'll let you know as soon as we have more info. We're so sorry for any trouble.
Posted Jan 15, 2020 - 14:54 UTC
This incident affected: Articulate 360 (Review 360).