Articulate.com: You may experience a delay when submitting a case or contact form and starting a sales chat
Incident Report for Articulate
Resolved
We've confirmed that our chat, case form, and contact form are working normally.
Posted 3 months ago. Mar 19, 2019 - 23:12 UTC
Monitoring
You should no longer experience a delay or error when you start a sales chat, or submit a case or the contact us form. We'll continue to monitor performance carefully.
Posted 3 months ago. Mar 19, 2019 - 22:02 UTC
Identified
We’ve identified an issue that may cause a delay or error when you submit a case or the contact us form. You may also encounter this issue when starting a sales chat. We’ll let you know when it’s fixed. So sorry for any trouble!
Posted 3 months ago. Mar 19, 2019 - 20:59 UTC
This incident affected: Articulate.com.