Articulate 360: Ordering temporarily unavailable

Incident Report for Articulate

Resolved

Our ordering systems are fully operational. We're sorry for the trouble!
Posted Mar 12, 2025 - 19:03 UTC

Monitoring

Our ordering systems are operational again. We are currently monitoring our systems' performance.
Posted Mar 12, 2025 - 16:34 UTC

Investigating

We are seeing errors in our ordering systems for Articulate 360 services. We have disabled ordering until this issue is resolved. We're sorry for the trouble, and we'll keep you updated on our progress!
Posted Mar 12, 2025 - 16:27 UTC
This incident affected: Articulate.com and Articulate 360 (Account Management).