Rise 360: Custom block editing isn’t loading

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 19:40 UTC

Monitoring

We've implemented a fix for the issue affecting custom block editing in Rise 360.
Custom block editing is working again, and we're monitoring the service to confirm everything remains stable. Please refresh your browser page before editing custom blocks.
Posted Jul 06, 2026 - 18:47 UTC

Identified

We've identified the cause of an issue affecting custom block editing in Rise 360.
We're working to restore normal functionality as quickly as possible. We'll share another update as we make progress. We appreciate your patience.
Posted Jul 06, 2026 - 18:33 UTC

Investigating

We're investigating an issue affecting custom block editing in Rise 360. Users see a "Something went wrong" page when they try to edit custom blocks.
We're actively investigating the cause and will share another update as soon as we have more information.
Posted Jul 06, 2026 - 18:08 UTC
This incident affected: Articulate 360 (Rise 360).