Articulate Systems Maintenance: Account Management and E-commerce

Incident Report for Articulate

Resolved

This is has been resolved and purchasing is now fully functional.
Posted Feb 11, 2026 - 19:41 UTC

Monitoring

The issue has been resolved. Customers can now complete new purchases and update existing subscriptions without any problems. We’re continuing to monitor the system to make sure everything remains stable.
Posted Feb 11, 2026 - 18:26 UTC

Investigating

We are currently investigating an issue where customers are unable to buy new subscriptions or add seats to your existing subscription. We'll will update as soon as we have more information.
Posted Feb 11, 2026 - 17:45 UTC
This incident affected: Articulate 360 (Account Management).