Articulate 360: Account management may be unavailable
Incident Report for Articulate
Resolved
We've confirmed that Account Management is working normally.
Posted Aug 04, 2020 - 20:24 UTC
Monitoring
Account Management is back up and running, and we're monitoring performance carefully. We'll keep you posted.
Posted Aug 04, 2020 - 20:07 UTC
Investigating
Hi there, Articulate 360 users. You may notice that your account management dashboard is unavailable on 360.articulate.com. We're investigating what went wrong, and we'll let you know as soon as we have more information. We're so sorry for the trouble.
Posted Aug 04, 2020 - 18:28 UTC
This incident affected: Articulate 360 (Account Management).