Salesforce: Maintenance Window Affecting Purchases

Incident Report for Articulate

Monitoring

A fix has been implemented and our team is monitoring the situation closely. We'll share another update once the maintenance window has concluded
Posted Sep 16, 2026 - 12:00 UTC

Identified

Salesforce is currently facing an outage and is impacting purchases. Our team is aware and actively working to restore full functionality as quickly as possible.
Posted Sep 16, 2026 - 11:03 UTC