Rise 360: Audio and Video Stuck in Processing

Incident Report for Articulate

Resolved

This incident has been resolved.
Posted Apr 25, 2026 - 01:07 UTC

Monitoring

A fix has been implemented, and we’re monitoring to ensure processing is completing successfully.
Posted Apr 24, 2026 - 23:57 UTC

Investigating

We’re investigating an issue in Rise 360 where audio and video are stuck in processing. Our team is working to identify the cause and restore normal functionality. We’ll share updates as we learn more.
Posted Apr 24, 2026 - 22:39 UTC
This incident affected: Articulate 360 (Rise 360, AI Assistant).