Possible errors with e-commerce purchases
Incident Report for Articulate
Resolved
This incident has been resolved. We're sorry for the trouble.
Posted about 1 month ago. Apr 25, 2019 - 17:27 UTC
Monitoring
We've implemented a fix for this issue. You should now be able to successfully complete your purchase. We'll continue to monitor performance carefully.
Posted about 1 month ago. Apr 25, 2019 - 16:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Apr 25, 2019 - 16:02 UTC
Investigating
We're experiencing some issues with our e-commerce process so you may encounter errors when trying to purchase apps on articulate.com. We're working on this, and we’ll let you know when we have any new information. We're sorry for the trouble.
Posted about 1 month ago. Apr 25, 2019 - 15:24 UTC
This incident affected: Store.