Rise 360: Unable to Upload logo and Images

Incident Report for Articulate

Resolved

This is now resolved. Thank you for your patience during this incident.
Posted Aug 27, 2025 - 18:08 UTC

Monitoring

A fix has been implemented, and uploading logos and images is working normally. We’re monitoring performance to ensure continued stability.
Posted Aug 27, 2025 - 16:33 UTC

Investigating

We’re currently investigating an issue in Rise 360 where users are unable to upload images in some parts of the application. We’re working to identify the cause and will provide updates as soon as more information is available.

Thank you for your patience!
Posted Aug 27, 2025 - 16:09 UTC
This incident affected: Articulate 360 (Rise 360).