Billing Platform: Unable to place orders

Incident Report for Articulate

Resolved

This incident has been resolved. Purchasing and processing of orders is working as expected.
Posted Mar 03, 2026 - 02:17 UTC

Monitoring

Our third party vendor has implemented a fix and we are currently monitoring the incident. Customers should be able to place orders through e-commerce, self-service, direct ordering, and partner ordering.
Posted Mar 03, 2026 - 01:14 UTC

Investigating

We're experiencing an outage with our ordering platform and are working with third party vendors to take corrective actions. Customers are unable to place orders through e-commerce, self-service, direct ordering, and partner ordering at this time.
Posted Mar 03, 2026 - 00:49 UTC
This incident affected: Articulate 360 (Account Management).