Possible errors with e-commerce purchases
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 16, 2019 - 21:53 UTC
Monitoring
We've implemented a fix for this issue. You should now be able to successfully complete your purchase. We'll continue to monitor performance carefully.
Posted 5 months ago. Apr 16, 2019 - 18:12 UTC
Investigating
We’re experiencing some issues with our e-commerce process that may result in an error when trying to purchase apps on articulate.com. We’re working on this, and we’ll let you know when we have any new information. We’re sorry for the trouble.
Posted 5 months ago. Apr 16, 2019 - 17:34 UTC
This incident affected: Store.