Reach 360: EU Users Can’t Log In

Incident Report for Articulate

Resolved

This incident has been resolved. Thank you for your patience while we resolved this matter.
Posted Sep 17, 2025 - 21:13 UTC

Monitoring

We’ve fixed the issue that prevented some EU users from logging into Reach 360. The system is back up, and we’re keeping a close eye to make sure everything stays stable. Thanks for your patience while we resolve this matter.
Posted Sep 17, 2025 - 19:25 UTC

Investigating

We’re investigating an issue that’s preventing some EU users from logging into Reach 360. Thank you for your patience. We’ll share updates as soon as we have more to share.
Posted Sep 17, 2025 - 17:58 UTC
This incident affected: Articulate 360 (Reach 360).