Articulate 360: Purchases for Articulate 360 are currently unavailable
Incident Report for Articulate
Resolved
We've confirmed that this issue is resolved. You can complete purchases for Articulate 360 subscriptions and seat adds.
Posted Feb 24, 2020 - 16:06 UTC
Investigating
We’re investigating an issue that is preventing tax from being properly calculated on Articulate 360 purchases, including adding seats to an existing subscription. As a result, you may not be able to complete your purchase. We’ll let you know as soon as we have more info. We’re sorry for any trouble!
Posted Feb 24, 2020 - 15:13 UTC
This incident affected: Account Management and Store.