Articulate 360: Issues with authoring in Rise 360 for Microsoft Edge users
Incident Report for Articulate
Resolved
We've resolved the issues with authoring in Rise 360 for Microsoft Edge users. Please be sure to refresh your browser to get the fix.
Posted 27 days ago. Aug 26, 2019 - 20:09 UTC
Identified
We've identified the issue with authoring in Rise for Microsoft Edge users, and we'll be rolling out a fix shortly. We're sorry for any trouble!
Posted 27 days ago. Aug 26, 2019 - 18:49 UTC
Investigating
We're investigating issues with authoring in Rise 360 for Microsoft Edge users. We'll let you know as soon as we have more information.
Posted 27 days ago. Aug 26, 2019 - 18:02 UTC
This incident affected: Articulate 360 (Rise).