Articulate 360: Issues with images loading on Rise 360 and Review 360
Incident Report for Articulate
Resolved
The issue with images loading across Articulate 360 is related to delays with accessing our services. We'll continue to update you here: https://www.articulatestatus.com/incidents/1zb6nqrzwycz.

We're so sorry for the trouble!
Posted Oct 22, 2019 - 23:25 UTC
Identified
We're seeing issues with images loading across Articulate 360, including Review 360 and Rise 360. You may also have issues exporting Rise 360 courses and uploading images to Rise 360 projects. We've identified the problem and working to fix the issue.
Posted Oct 22, 2019 - 22:21 UTC
This incident affected: Articulate 360 (Review, Rise).